icon-document-pdficon-document-pdf-fullicon-document-texticon-searchicon-share-facebookicon-share-googleplusicon-share-linkedinicon-share-twittericon-staricon-video-camera

Board Introduction

 

Depending on the role you have within a board, you have a set of tools at your disposal to mark-up, change, and move content.

As an Editor, you can use all of the Conceptboard tools. As a Reviewer, you only have access to certain tools to be used for editing content and giving feedback.

Please note, as a Reader, you do not have access to any of the tools on the board.

All your tools are located on the top toolbar. As you select a tool, more options will be shown to change any details of the tools.

How Do You Navigate Around The Board?

How To Move

To move around the board, select the Browse tool M , click anywhere on the board, and drag.

When you are in a tool mode, you can press and hold the Spacebar and drag, without having to switch back to Browse mode.

How To Zoom

There are a few ways to zoom in and out of your board. Depending on your preference, you can:

  1. Use the mouse wheel or scrollbar motion on a track pad to zoom in and out of a board. Press Shift to pan around the board.
  2. Use the drop down menu, or use the Zoom tool to select or click an area. Press Shift and click when you want to zoom back out.
  3. Hover the mouse pointer over the zoom value in the top bar or the minimap while using the mouse wheel/trackpad to zoom in or out. 

You can also select or deselect the option for scroll to zoom. Click on the drop down menu and deselect scroll to move. Then, use the scroll motion on the trackpad or mouse wheel to pan around the board. In any tool mode, press Shift and use the mouse wheel or scrollbar motion on a trackpad to zoom without switching modes.

Board Options

Your logo takes you back to your boards overview page.

Click on the title of your board to edit the title. 

Board Menu

When accessing the Board menu, you can open board settings and the Updates and Approval menu, change the board background color, share your board, download files, or use the Google Drive and Salesforce integrations. You can also open a new blank board and save as a new board or duplicate the board. 

Edit Menu

When items are selected in your boards, click on the Edit menu to have further options. From this menu, you can undo actions, copy or delete items, and group items together. When one item is selected, you can directly download the item as an image or it's original file from this menu. 

Insert Menu

You can access the Insert menu from the top toolbar, or from clicking on the "+" icon in the top left corner of your boards. From this menu, you can upload files from your computer, embed video or audio files, and import items from ImageRelay and Dropbox

When using a tablet, you can take pictures and directly insert them in your board. 

Tip: Watch the video guide on how to add content.

View Menu

When accessing the View menu, you can show the grid, select full screen mode, or hide the menu. In this option, you can also see the how other users with different access roles to the board will see their board. For instance, if you select Read mode, you will no longer be able to access the tools. 

Any option in the menu that have a checkmark next to it means that is has already been selected. 

Conference Menu

When clicking on this menu, you will find all of your collaboration tools with a brief description of what they do. 

Help Menu

Here you will be able to open the keyboard shortcuts menu, access helpful videos, tutorials and FAQs, and open a support ticket with us if you have any questions. 

Board Tools

Use the select tool and select the drop down menu, when you want to move, crop and slice, resize your added content. 

Select the board tools drop down menu to add elements to the board, such as, scribbling, highlighting, and to add shapes, sticky notes, or text boxes, headlines. 

To leave a comment, select the comment tool or hit C on your keyboard, and click and drag to create a comment box. Make sure the arrow of the comment box points directly to the subject being talked about. 

Additional Options

Live Participants and Account Menu

In the top right corner, you will see all board participants that are currently working live with you on the board. You can click on a participant's name to access additional information about them. 

By clicking on the drop down menu next to your name, you will find further options for your account. 

Share Button

Click the "Share" button, located in the top right corner of your boards, to edit the Board Access Management

From the share dialog, you can invite users, share the board link, restrict access to specific users and remove guest access.

You can also subscribe and unsubscribe from the Board Update alerts by clicking on the Bell icon next to your name.

Full Screen Mode and Minimizing Top Bar

You can switch to Full screen mode and the interface can be hidden away.

You can also minimize the headline toolbar by clicking the double arrow pointing up in the right corner.

Side Navigation Bar

The board alerts, summary, outline, and conference tools, and minimap are located into one simple side navigation panel on the left side of the board. 

Alerts

This is where you are notified when someone @mentions you. You can click on the alert to navigate to it directly on the board. 

Tasks and Comments

You can filter by:

  • All tasks and comments
  • All open tasks
  • My @mentions
  • My open tasks 

Board Sections Outline

  • Add a file into your outline by selecting it and clicking the board outline icon in the top toolbar.
  • You can include headlines, sticky notes, uploaded files, and sections in the board outline.
  • You can create sections within your boards that are automatically added to your outline. 
  • To edit your outline, right click an item listed to access more options. There, you can easily rename, reorganize, and export each item.
  • You can select multiple sections at once and export them as a PDF. 

Live Pointers

Turn on live pointers when there are multiple users on the board and their location will show up on the minimap. This is a great feature to use during a group meeting because the exact view port and pointer of each user will make it easier to see exactly what element or section each person is talking about.

Tip: Check out the video guide on presentations, video conferencing, and live pointers

Video Conferencing 

Video conferencing is located in the bottom left corner of your board, and is available on any Web-RTC enabled browser. Click the video icon to turn on video conferencing. Other user's in the board can listen, or turn on their own video camera as well.  

For more info, check out our video conferencing article.

Moderator Mode: Live Presentations

To start a live presentation, click the moderator mode in the lower right hand corner of the board. This will take control of every board participant's view. The other users will see your live mouse cursor and move around the board with you. A flashing symbol is shown over the icon of the user currently in moderator mode. 

Chat

Use the board chat for quick conversations. You can clear the board chat at any time to delete messages permanently. It is very useful during presentations to ask questions. The chat bar will have a red glowing dot when there are new messages.

Mini map

The minimap is located on the bottom left of your board where you can see a complete overview of the board itself. Each item on the minimap shows up as an outline. You can click on any item in the minimap and it will directly bring you to that location on the board. 

Was this article helpful?
0 out of 0 found this helpful