icon-document-pdficon-document-pdf-fullicon-document-texticon-searchicon-share-facebookicon-share-googleplusicon-share-linkedinicon-share-twittericon-staricon-video-camera

Board Menus and Options

When you are inside a board you have various menus and options to work with. 

Menus

Board Menu

hc-board-menu-conceptboard.png

When accessing the Board menu, you can open board settings and the Updates and Approval menu, change the board background color, share your board, download files, or use the Google Drive and Salesforce integrations. You can also open a new blank board and save as a new board or duplicate the board. 

Edit Menu

hc-edit-menu-conceptboard.png

When items are selected in your board , click on the Edit menu to have further options. From this menu, you can undo actions, copy or delete items. When one item is selected, you can directly download the item as an image or in it's original file format from this menu by clicking on the "Export" button. 

Insert Menu

hc_insert_menu_conceptboard.png

You can access the Insert menu from the top toolbar, or from clicking on the "+" icon in the top left corner of your boards. From this menu, you can upload files from your computer, embed video or audio files, insert templatesimport items from ImageRelay and Dropbox

When using a tablet, you can take pictures and directly insert them in your board. 

Tip: Watch the video guide on how to add content.

View Menu

hc-view-menu-conceptboard.png

When accessing the View menu, you can select to show grid, select full screen mode, select to show user cursors (live pointers), or hide the menu. If you select the Mode option, you can see how other users with different access roles to the board will see their board. For instance, if you select Read mode, you will no longer be able to access the tools. 

Any option in the menu that has a checkmark next to it means that is has already been selected. 

Help Menu

hc-help-menu-conceptboard.png

Here you will be able to open the keyboard shortcuts menu, access helpful videos, tutorials and FAQs, and open a support ticket with us if you have any questions. 

 

Board Options

hc-additional-options-conceptboard.png

Live Participants and Account Menu

In the top right corner, you will see all board participants that are currently working live with you on the board. You can click on a participant's name to access additional information about them. 

By clicking on the drop down menu next to your name, you will find further options for your account. 

Share Button

Click the "Share" button, located in the top right corner of your boards, to edit the Board Access Management

From the share dialog, you can invite users, share the board link, restrict access to specific users and remove guest access.

You can also subscribe and unsubscribe from the Board Update alerts by clicking on the Bell icon next to your name.

Full Screen Mode and Minimizing Top Bar

You can switch to Full screen mode and the interface of your browser and operating system can be hidden away, while the Conceptboard window is enlarged to cover your whole display.

You can also minimize the headline toolbar by clicking the double arrow pointing up in the right corner.

Side Navigation Bar

hc-sidebar-conceptboard.png

The board alerts, tasks, the board outline/sections, and minimap are located in one simple side navigation panel on the left side of the board. 

Alerts

This is where you are notified when someone @mentions you. You can click on the alert to navigate to where you were mentioned directly on the board. 

Tasks and Comments

You can filter by:

  • All tasks and comments
  • All open tasks
  • My @mentions
  • My open tasks 

Board Sections Outline

  • Add a file into your outline by selecting it and clicking the board outline icon in the floating toolbar.
  • You can include shapes, text boxes, sticky notes, uploaded files, and sections in the board outline.
  • You can create sections within your boards that are automatically added to your outline. 
  • To edit your outline, right click an item listed to access more options. There, you can easily rename, reorganize, and export each item.
  • You can select multiple sections at once and export them as a PDF. 

Live Pointers

Turn on live pointers when there are multiple users on the board and their location will show up on the minimap. This is a great feature to use during a group meeting because the exact view port and pointer of each user will make it easier to see exactly what element or section each person is talking about.

Tip: Check out the video guide on presentations, video conferencing, and live pointers

Video Conferencing 

Video conferencing is located in the bottom left corner of your board, and is available on any Web-RTC enabled browser. Click the video icon to turn on video conferencing. Other user's in the board can listen, or turn on their own video camera as well.  

For more info, check out our video conferencing article.

Moderator Mode: Live Presentations

To start a live presentation, click the moderator mode in the lower right hand corner of the board. This will take control of every board participant's view. The other users will see your live mouse cursor and move around the board with you. A flashing symbol is shown over the icon of the user currently in moderator mode. 

Chat

hc-chatting-conceptboard.png

Use the board chat for quick conversations. You can clear the board chat at any time to delete messages permanently. It is very useful during presentations to ask questions. The chat bar will have a red glowing dot when there are new messages.

Conceptboard Logo and Board Title

hc-board-logo-and-title.png

Your logo takes you back to your boards overview page.

 Click on the title of your board to edit the title

Minimap

hc-minimap-conceptboard.png

The Minimap is located on the bottom left of your board where you can see a complete overview of the board itself. Each item on the minimap shows up as an outline. You can click on any item in the minimap and it will directly bring you to that location on the board. 

Change the Board Background

To change the color of the board background, click on the Board menu via the top toolbar, and choose Background. 

hc-background-conceptboard.png

You can then choose from 9 full color background options or define your custom color: 

hc-color-background-conceptboard.png

Archive a Board

Archiving allows you to remove old or completed work from your boards overview page without losing it forever.

How to Archive a Board

hc_move_board_archive_conceptboard.png

Access your Board Settings by either hovering over the board in the Boards page and clicking on the Settings icon or by clicking in the Board menu while in a board, and selecting Settings.  

Once the Settings has opened, click on the 'Archive' button at the bottom of the dialog box. Your board will then be moved to the Archive and you will no longer see it in your Boards page.

Please note, you can only archive a board if you are the owner of the board or an Editor

Archive Page

To see all of your archived boards, click on the Archive button in the left side panel of your Home page or Boards page.

You have the same functions in the Archive page as you do in the Boards page.

You can easily search all archived content by using the search bar or by sorting your archived boards and projects into 3 categories:

  • All: all boards and projects you can access
  • Owned by me: only the boards and projects you have created
  • Shared with me: only the boards and projects that have been shared with you

You can also view your archived boards in various ways. Click on the drop down menu in the top right corner and choose between viewing all content by last modified or in alphabetical order. With those two options, you can then view your boards as a list or as tiles. 

How to Un-Archive a Board

hc_remove_board_from_archive_conceptboard.png

If you would like to view a board that is archived, you can click on the board in the Archive page and view it as a Reader. To make any edits or changes to the boards, you will first need to un-archive it.

Hover over the board icon in the list of your archived items, and click on the settings icon. You will then be able to choose to un-archive the item by clicking on the Un-Archive button located at the bottom of the dialog box. The board will disappear from the Archive page and reappear in the Boards page. 

Was this article helpful?
0 out of 0 found this helpful